Vamos a aprender como tener dos subredes separadas con el mismo espacio de direccionamiento. También habilitaremos la comunicación IP entre ellas.

El truco es usar NAT de red en ambos routers. Déjame explicarte.

Topología

Usaremos la siguiente. Como vemos, ambas subredes SW1 y SW2, tienen el mismo direccionamiento IP.

Topología

Problema

¿Cómo pueden comunicarse los hosts de la subred SW1 con los hosts de la subred SW2? Por lo que sabemos, los hosts que utilizan Ethernet como tecnología de Capa 2, no podrán comunicarse de esta manera. El host en SW1 no utilizará su puerta de enlace para llegar al host en SW2. Hará ARP a la dirección broadcast de la subred SW1 porque la dirección IP del host en SW2 se encuentra en su misma subred.

Solución

Para conseguir comunicación entre ellos necesitamos enmascarar ambas redes. De esta forma, los hosts de la subred SW1 parecerán estar en otra red a los hosts de la subred SW2, y viceversa. Haremos esto usando un comando nat muy simple en cada router.

  • Los hosts en SW1 parecerán estar en la subred 172.16.10.0/24 a los hosts en SW2.
  • Los hosts en SW2 parecerán estar en la subred 172.16.20.0/24 para los hosts en SW1.

Veamos los pasos:

  • Habilite la traducción nat en R1 y R2.
  • Traduzca la red 192.168.10.0/24 en R1 y R2 a 172.16.10.0/24 y 172.16.20.0/24 respectivamente.
  • Añadir rutas estáticas a R1, R2 y BB1.

Configuraciones

R1

Current configuration : 1118 bytes
 !
 upgrade fpd auto
 version 12.4
 service timestamps debug datetime msec
 service timestamps log datetime msec
 no service password-encryption
 !
 hostname R1
 !
 boot-start-marker
 boot-end-marker
 !
 logging message-counter syslog
 !
 no aaa new-model
 ip source-route
 ip cef
 !
 !
 !
 !
 no ip domain lookup
 no ipv6 cef
 !
 multilink bundle-name authenticated
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 memory-size iomem 0
 archive
 log config
 hidekeys
 !
 !
 !
 !
 !
 !
 !
 !
 !
 interface FastEthernet0/0
 ip address 10.0.1.1 255.255.255.0
  ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
 !
 interface FastEthernet0/1
 ip address 192.168.10.1 255.255.255.0
  ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 !
 ip forward-protocol nd
 ip route 172.16.10.0 255.255.255.0 Null0
 ip route 172.16.20.0 255.255.255.0 10.0.1.10
 no ip http server
 no ip http secure-server
 !
 !
 ip nat inside source static network 192.168.10.0 172.16.10.0 /24
 !
 !
 !
 !
 !
 !
 !
 control-plane
 !
 !
 !
 mgcp fax t38 ecm
 !
 !
 !
 !
 gatekeeper
 shutdown
 !
 !
 line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
 line aux 0
 stopbits 1
 line vty 0 4
 login
 !
 end

R2

Current configuration : 1118 bytes
 !
 upgrade fpd auto
 version 12.4
 service timestamps debug datetime msec
 service timestamps log datetime msec
 no service password-encryption
 !
 hostname R2
 !
 boot-start-marker
 boot-end-marker
 !
 logging message-counter syslog
 !
 no aaa new-model
 ip source-route
 ip cef
 !
 !
 !
 !
 no ip domain lookup
 no ipv6 cef
 !
 multilink bundle-name authenticated
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 memory-size iomem 0
 archive
 log config
 hidekeys
 !
 !
 !
 !
 !
 !
 !
 !
 !
 interface FastEthernet0/0
 ip address 192.168.10.2 255.255.255.0
  ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
 !
 interface FastEthernet0/1
 ip address 10.0.2.2 255.255.255.0
  ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 !
 ip forward-protocol nd
 ip route 172.16.10.0 255.255.255.0 10.0.2.10
 ip route 172.16.20.0 255.255.255.0 Null0
 no ip http server
 no ip http secure-server
 !
 !
 ip nat inside source static network 192.168.10.0 172.16.20.0 /24
 !
 !
 !
 !
 !
 !
 !
 control-plane
 !
 !
 !
 mgcp fax t38 ecm
 !
 !
 !
 !
 gatekeeper
 shutdown
 !
 !
 line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
 line aux 0
 stopbits 1
 line vty 0 4
 login
 !
 end

BB1

Current configuration : 977 bytes
 !
 upgrade fpd auto
 version 12.4
 service timestamps debug datetime msec
 service timestamps log datetime msec
 no service password-encryption
 !
 hostname BB1
 !
 boot-start-marker
 boot-end-marker
 !
 logging message-counter syslog
 !
 no aaa new-model
 ip source-route
 ip cef
 !
 !
 !
 !
 no ip domain lookup
 no ipv6 cef
 !
 multilink bundle-name authenticated
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 memory-size iomem 0
 archive
 log config
 hidekeys
 !
 !
 !
 !
 !
 !
 !
 !
 !
 interface FastEthernet0/0
 ip address 10.0.1.10 255.255.255.0
 duplex auto
 speed auto
 !
 interface FastEthernet0/1
 ip address 10.0.2.10 255.255.255.0
 duplex auto
 speed auto
 !
 ip forward-protocol nd
 ip route 172.16.10.0 255.255.255.0 10.0.1.1
 ip route 172.16.20.0 255.255.255.0 10.0.2.2
 no ip http server
 no ip http secure-server
 !
 !
 !
 !
 !
 !
 !
 !
 !
 control-plane
 !
 !
 !
 mgcp fax t38 ecm
 !
 !
 !
 !
 gatekeeper
 shutdown
 !
 !
 line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
 line aux 0
 stopbits 1
 line vty 0 4
 login
 !
 end

Verificación

R1 prueba

R1(config)# do ping 172.16.20.2 so f0/1
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 172.16.20.2, timeout is 2 seconds:
 Packet sent with a source address of 192.168.10.1
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 64/109/128 ms
 R1(config)# do sh ip nat tra
 Pro Inside global      Inside local       Outside local      Outside global
 icmp 172.16.10.1:4     192.168.10.1:4     172.16.20.2:4      172.16.20.2:4
 --- 172.16.10.1        192.168.10.1       ---                ---
 --- 172.16.10.0        192.168.10.0       ---                ---
 R1(config)#

R2 prueba

R2(config)# do ping 172.16.10.1 so f0/0
 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
 Packet sent with a source address of 192.168.10.2
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 100/121/136 ms
 R2(config)# do sh ip nat tra
 Pro Inside global      Inside local       Outside local      Outside global
 icmp 172.16.20.2:2     192.168.10.2:2     172.16.10.1:2      172.16.10.1:2
 icmp 172.16.20.2:4     192.168.10.2:4     172.16.10.1:4      172.16.10.1:4
 --- 172.16.20.2        192.168.10.2       ---                ---
 --- 172.16.20.0        192.168.10.0       ---                ---
 R2(config)#